VPN to Codesys 3.5 PLC unable to connect

I am using a codesys 3.5 PLC over the Ixon VPN

I can ping the PLCs IP address successfully ( but cannot connect to the PLC

I have another non PLC related device which I can connect to over the VPN without difficulty

Has anyone else had this problem.



An update on this, the scan for CPUs does not work over the VPN.
Entering the IP address directly worked.



Hello Tony,

Do I understand correctly that you were able to solve the problem yourself?
As you commented it’s indeed not possible to scan for devices over VPN. You have to connect directly on IP within Codesys.

If you need any further assistance, please let me know.

Hi Martjin,
Yes, I was able to solve this once I realised that I could not Scan for devices over the VPN.

Thank you for your assistance.

Hi all,
I want to share with you ma experience regarding the Codesys Gateway and problems with connecting via the IXON VPN.

I have a several versions of Codesys installed on my computer and the VPN connection to the PLC worked fine. After a while I experimented with older versions of Codesys and uninstalled it after all. this mast have messed up my Codesys Gateway configuration because I couldn’t connect to the PLC via the VPN anymore. I repaired my installation of Codesys but nothing changed. The Gateway indicated the green light, I could ping the PLC but the connection was unsuccessful . Finally I installed just the latest version of the Codesys Gateway on my computer and it worked.

1 Like